Working with Events in Joomla! – JEvents

*Instructor for this Workshop:*

Laura Gordon

Web Development, School of Arts and Sciences
# TABLE OF CONTENTS

- Working with Events in Joomla! – JEvents .......................................................... 3
- Welcome .................................................................................................................. 3
- Getting Started ........................................................................................................ 3
- What is Joomla!? ...................................................................................................... 3
- Working with Images and PDFs ............................................................................ 4
- What is a Component? ............................................................................................ 4
- Overview of JEvents .............................................................................................. 4
- To access JEvents: ................................................................................................... 4
- Examples of JEVENTS on our sites .................................................................... 5
- Events on home page ............................................................................................. 5
- Events Calendar Page ............................................................................................. 5
- Events ‘FLOAT’ Page ............................................................................................ 6
- Managing Event Categories .................................................................................. 7
- Working with Events .............................................................................................. 9
- Creating an Event .................................................................................................... 9
- Work with Images / PDFs ..................................................................................... 10
- Practice: Create Additional Events ...................................................................... 12
- Editing Events ......................................................................................................... 13
- Creating a Repeating Event .................................................................................. 14
- Editing Repeating Events ..................................................................................... 15
- Displaying Events in Sidebar Module ................................................................... 17
- Displaying JEvents as a Menu Item .................................................................... 20
- Displaying Events in a List Format ........................................................................ 20
- Displaying Events in Calendar Format (as a Month view) .................................... 23
- Displaying Events in Date Range with Float Format (with Thumb images) .......... 25
- Logout from Joomla! ............................................................................................... 28
- Future Workshops .................................................................................................. 28
Working with Events in Joomla! – JEvents

WELCOME

Once you arrive:

GETTING STARTED

1. If you are working from home or another off-campus location, log on to the Rutgers VPN from your computer; you can find instructions here:

   https://sasit.rutgers.edu/how-to-guides/working-remotely/vpn-instructions

2. Open a web browser on your computer (Firefox, Chrome, or Safari)
3. Go to the website:
   https://www.sas.rutgers.edu/cms/training

WHAT IS JOOMLA!?

Joomla! is Content Management System (CMS) software that runs on a web server and allows you to update your web site through a browser (such as Google Chrome, Mozilla Firefox, or Safari). A content management system simplifies the process of updating a website by eliminating the need to edit HTML or use web design software.

Visit https://www.joomla.org/ for more information on Joomla.
WORKING WITH IMAGES AND PDFS
When creating events, you may often want to upload a flyer for the event. The flyer should be in a PDF file, and the text in it should be selectable (by clicking and dragging with the mouse) so that screen reader software can read the text in the PDF. You should also have a specific image that you can add to the event.

For today’s workshop, you can download some sample events flyers and images.

1. Go to:  
https://www.sas.rutgers.edu/cms/training/images/files/jevents-sample-events.zip
2. Save the ZIP file to your computer
3. Extract the ZIP file
4. There will be sample PDF flyers and images corresponding to the flyers that you can add to your events later in this workshop.

WHAT IS A COMPONENT?
A component in Joomla! is an extension that allows you to store and display different types of content than you can with standard Joomla! articles. Examples include DOCman (documents), Ignite Gallery (image galleries), JEvents (calendar events), and SmartSlider (slideshows).

A Joomla Component might also include a module as well, which can display information stored in the component on the website.

OVERVIEW OF JEVENTS
JEvents is a component that stores information about events. You can organize your events into categories, which helps you display them in different areas on the website. In fact, events can actually exist in multiple categories. You can display events in a module position or via a menu item.

TO ACCESS JEVENTS:
1. Login to the back end of Joomla!:
http://www.sas.rutgers.edu/cms/training/administrator
2. On the top menu, click on Components > JEvents
EXAMPLES OF JEVENTS ON OUR SITES

https://www.sas.rutgers.edu/cms/deptdemo/

EVENTS ON HOME PAGE

 EVENTS CALENDAR PAGE

https://www.sas.rutgers.edu/cms/deptdemo/events/jevents-calendar/month.calendar/2021/04/16/-
**Events ‘FLOAT’ Page**

https://www.sas.rutgers.edu/cms/deptdemo/events/event-float/range.listevents/-
MANAGING EVENT CATEGORIES

A category should be created in JEevents when you know you have at least 3-5 events that you want to be ‘sub organized’. An event can link to ‘multiple’ categories, this gives you more control of the events and the display of them. Once events are in categories you can create menu items, have events listed on the ‘side bar or in a module’, and various classifications. They can also be displayed with different colors on the site.

An example of a live site with multiple categories / organization is Economics:

https://economics.rutgers.edu/news-and-events/workshops/econometrics/range.listevents/

1. Hover the mouse over the left sidebar, then select **Manage Categories**:

2. Click on **NEW** to create a new category
3. Title: “[Your Name] Events” (see #1 below)
4. Parent: select WORKSHOP EVENTS (see #2 below)
5. Click Options (see #3 below)
6. Click in “Choose Colour” and use the color picker to select a color.
7. Click **SAVE & CLOSE** (see #4 below)
Working with Events in Joomla! – JEvents
WORKING WITH EVENTS
Hover the mouse over the left sidebar, then select Manage Events:

Then click New to create a new event.

CREATING AN EVENT
Event Details (COMMON tab)
1. Title: enter a title for the event (see #1 below)
2. Events Calendar: select “Default” (see #2 below)
3. Categories: select the category you created (and at least one other category) (see #3 below)
4. Description: Enter a description of the event in the text area (see #4 below)
**WORK WITH IMAGES / PDFS**

**Edit Images**

When an image is added to an event, this image should be modified prior to uploading it to Joomla. We have already uploaded sample images to use for this class. The images should not contain text or details about the event, in fact you should not use the ‘flyer’ as the image. Perhaps a ‘portion’ of the flyer as the image.

If you only have a pdf version of the image, there are several online tools that can be used:

1. Convert the file to a jpg: [https://pdf2jpg.net/](https://pdf2jpg.net/)
2. Crop the file using resizeimage.net

For more documentation about Image editing: [https://sasit.rutgers.edu/how-to-guides/web-development-documentation/articles](https://sasit.rutgers.edu/how-to-guides/web-development-documentation/articles)

Click on the ‘tag’ for Image Editing.

Here is an example of an image vs. a flyer
Add Image & Flyer to Event

1. Scroll to the bottom of the Create an Event page.
2. Under “Select Image,” click Select (see #1 below), then browse to “Events.”
3. Click Upload, then upload one of the images from the ZIP file and click Insert.
4. Under “Image Title,” enter a title for your image (see #2 below).
5. Under “Upload File,” click Choose File (see #3 below), then upload the PDF from the ZIP file you downloaded earlier.
6. Then click Upload (see #4 below).
Date & Time (CALENDAR tab)
1. Scroll back to the top of the Create an Event page
2. Click the CALENDAR tab
3. Under Start Date, click the calendar icon, then select a date for the event
4. Under Start Time, enter the start time, then click AM or PM
5. Under End Time, enter the end time, then click AM or PM
6. Click SAVE & CLOSE

**PRACTICE: CREATE ADDITIONAL EVENTS**
1. Create at least 2 more events using different dates and times
2. Upload an image and a .pdf for each event, using the files from the ZIP file
3. Put each event in your own category, as well as one other category
4. Go to https://www.sas.rutgers.edu/cms/training/jevents-by-month/ to see how your events look in the Joomla! front-end.
EDITING EVENTS

Working with Images
Select one of your events and scroll to the bottom of the Create an Event page.

1. Click on the X to remove the current image, or just click select to find a new image and upload.
2. Be sure to update the Image Title (this is displayed as ‘alt text’).

![Image Title](images/events/5ae753a6) Select Image

Working with Files
1. Click on Delete to remove file
2. Click Choose file
3. Find a different file, then click Upload to save the pdf file

When done, click SAVE & CLOSE
CREATING A REPEATING EVENT

If an event occurs once a week, or once a month, you can create it as a repeating event. Then you can modify the individual occurrences; for example, you can delete a repetition of the event that falls on a holiday.

Repeating events work best if the majority of the repeating events are similar and do not have to be edited – for example, events that occur at the same time of day, or the same day of the week.

1. Create a new event as you normally would; the details on the Common tab should be common to all events in the series
2. Click the CALENDAR tab
3. Select the date and time as you did for previous events.
4. Under “Repeat Type” click MONTHLY (see #1 below).
5. You can either enter a number under “Repeat Count” (to repeat the event a specific number of times) or select “Repeat Until” and set an end date for the series (see #2 below).
6. Select “By Day” (see #3 below).
7. Under “Which Week(s)?” un-select any weeks of the month that the event should not recur on (see #4 below).
8. Click SAVE & CLOSE
9. When notified “This will replace all repeats and will delete all existing exceptions. Do you wish to continue?” Click OK.
**EDITING REPEATING EVENTS**

To edit repeating events (for example, to remove a specific repeat) go to the MANAGE EVENTS page. Click the icon in the “Repeats” column for the event:

<table>
<thead>
<tr>
<th>Event Summary</th>
<th>Repeats</th>
<th>Event Creator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lecture series test</td>
<td></td>
<td>konczal(Eddie Konczal)</td>
</tr>
<tr>
<td>British Studies Lecture #1</td>
<td></td>
<td>konczal(Eddie Konczal)</td>
</tr>
</tbody>
</table>

**To remove 1 or more repeating events**

Click on the check box to the left of the event (see #1 below), and select **DELETE** (see #2 below).

Click **OK** to delete the repeat.
To edit one of the repeating events
Click on the check box to the left of the event (see #1 below), and select **EDIT** (see #2 below).

Make your changes to the event, then **SAVE & CLOSE**.

**Editing main event for a repeating event**
If you go to **MANAGE EVENTS** and change the date settings for a repeating event, it will recreate all repeating events, and any details changed for specific events will be lost. For example, if you deleted a repeat for 12/25/2020, then edited the date settings for the main event, the 12/25 repetition will be recreated, and you will need to delete it again.
DISPLAYING EVENTS IN SIDEBAR MODULE

Once you have added some events to JEvents, you can display them on the website front end using either a module or a menu item.

In the below example, the “Arts & Aesthetics Events” right sidebar module displays upcoming events:

![Sidebar Module Displaying Events](image-url)
Creating a “JEvents - Latest Events Module”:

1. Go to Extensions > Modules
2. Click New
4. Title: enter your name followed by “Events” (see #1 below)
5. Position: select “Sidebar B [sidebar-b]” from the dropdown menu – note: you can start typing “sidebar” to narrow down the list (see #2 below)
6. Select categories – leave blank for all: select your category and at least one other category (see #3 below)

7. Target Menu item: select “*** JEvents by Month ***” (this means that when an event is selected, you will be taken to this menu item).
8. **Maximum Events to display**: enter “5” (or more) *(see #1 below)*
9. **Display events from the next ? days**: increase this number to 60 or more *(see #2 below)*
10. **Past Events Only**: change to “Future Events Only” *(see #3 below)*

![Form fields](image)

11. Click the “Menu Assignment” tab *(see #1 below)*
12. Change “Module Assignment” to “Only on the pages selected” *(see #2 below)*
13. Clear all the check boxes by clicking “None” to the right of “Select: All” *(see #3 below)*
14. Find your menu item listed under “JEvents by Month” and click the check box for it.
15. Click **Save & Close**.
DISPLAYING JEVENTS AS A MENU ITEM
You can also create menu items to display events. There are many options for configuring menu items. We will look at three: List of Events, Calendar, and Date Range with Float Format:

DISPLAYING EVENTS IN A LIST FORMAT
1. Go to Menus > Main Menu
2. Find the menu item with your name under “JEvents by Month” and click on it.
3. On the “Details” tab, for “Menu Item Type” click Select:

4. Click JEvents – Core (see #1 below), then select “List of Events” (see #3 below):
5. Click the “Options” tab (see #1 below)
6. Under “Select columns to display,” select the below columns from the “Click to add column” menu (see #2 below):
   a. Title Link
   b. Start Date
   c. Start Time
   d. Category
7. Select categories – leave blank for all: select your category and at least one other category (see #3 below)
8. End relative to today: enter “+2m” (for two months)
9. Click Save & Close

When you view your menu item on the front end, the events should appear in a table format:
<table>
<thead>
<tr>
<th>Title Link</th>
<th>Start Date</th>
<th>Start Time</th>
<th>Category</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test event</td>
<td>Tuesday, October 13, 2020</td>
<td>10:00am</td>
<td>Eddie K. Category</td>
</tr>
<tr>
<td>Lecture series test</td>
<td>Thursday, October 15, 2020</td>
<td>03:00pm</td>
<td>Eddie K. Category</td>
</tr>
<tr>
<td>British Studies Lecture #1</td>
<td>Friday, October 16, 2020</td>
<td>08:00am</td>
<td>Lectures, Eddie K. Category</td>
</tr>
<tr>
<td>Fall Lecture: Mireille Lee, Vanderbilt</td>
<td>Monday, October 19, 2020</td>
<td>05:00pm</td>
<td>Lectures</td>
</tr>
<tr>
<td>Lecture series test</td>
<td>Thursday, October 22, 2020</td>
<td>08:00am</td>
<td>Eddie K. Category</td>
</tr>
<tr>
<td>Lecture series test</td>
<td>Thursday, November 05, 2020</td>
<td>08:00am</td>
<td>Eddie K. Category</td>
</tr>
<tr>
<td>Lecture series test</td>
<td>Thursday, November 12, 2020</td>
<td>08:00am</td>
<td>Eddie K. Category</td>
</tr>
<tr>
<td>Lecture series test</td>
<td>Sunday, November 15, 2020</td>
<td>03:00pm</td>
<td>Eddie K. Category</td>
</tr>
</tbody>
</table>
DISPLAYING EVENTS IN CALENDAR FORMAT (AS A MONTH VIEW)

1. Go to **Menus > Main Menu**
2. Find the menu item with your name under “JEvents by Month” and click on it.
3. On the “Details” tab, for “Menu Item Type” click **Select**
4. Click **JEvents – Core**, then select “View by Month”
5. Click the “Component” tab (see #1 below)
6. **Select categories – leave blank for all**: select your category and at least one other category (see #2 below)
7. Click **Save & Close**
When you view your menu item on the front end, the events should appear in a calendar format:
**DISPLAYING EVENTS IN DATE RANGE WITH FLOAT FORMAT (WITH THUMB IMAGES)**

1. Go to **Menus > Main Menu**
2. Find the menu item with your name under “JEvents by Month” and click on it.
3. On the “Details” tab, for “Menu Item Type” click **Select**
4. Click **JEvents – Core**, then select “Date Range”
5. Click the “Range Date & Time Settings” tab (see #1 below)
6. For “Rel/Abs Date Range” select **Relative** (see #2 below)
7. **End relative to today**: enter “+2m” (for two months)
8. Click the “Options” tab
9. Choose JEvents Theme: select “Float”

10. Select categories – leave blank for all: select your category and at least one other category
11. Click Save & Close

Go to your menu item on the front end to see what the list of events looks like.
EDIT EVENTS IN FRONT END
Events can be easily edited by the staff and faculty of the department (as long as they have editing access) from the front end of the website.

The SAS-IT team can add a menu item if needed to the front end for registered users.

Click on Manage events, then any event can be edited (depending on security settings)
LOGOUT FROM JOOMLA!
Click the profile icon to the upper right of your Joomla! administrator page, then click “Logout”:

![CMS Sandbox](image)

FUTURE WORKSHOPS
Please visit:
https://sas-it.rutgers.edu/itservices/web-development-and-support/workshops-and-training